Skip to main content

VLANs, ejercicio práctico con Swiches y Routers CISCO

::[INTRO]::

Una vez más frente a los routers CISCO. Esta vez la película va de como realizar configuraciones en enrutadores y swiches CISCO, en especial, lo referente a enlaces WAN, LAN y VLANs.

Este problema me lo encontré en el Politécnico Colombiano Jaime Isaza Cadavid y aquí le doy solución para futura referencia.

Las herramientas que serán utilizadas para desarrollar este problema incluye el Packet Tracer de CISCO.

 

::[PROBLEMA]::

La empresa OTEON S.A. ha sido seleccionada para la implementación y configuración de la red LAN y WAN de la empresa XYZ, la cual tiene como sedes las ciudades de Medellín y Bogotá, para esta implementación se ha dado la mayor autonomía en la creación del direccionamiento IP bajo ciertos parámetros exigidos por la compañia, adicionalmente se solicita tener en cuenta las siguientes variables:

  1. Configurar el enlace WAN entre las sedes de Bogotá y Medellín, adicionalmente tener en cuenta las siguientes recomendaciones:
    • El enrutamiento debe ser estático.
    • El enlace WAN no debe superar mas de 2 host.
  2. La ciudad de Medellín debe tener tres VLANs creadas para: Usuarios, Proveedores, y Visitantes, las cuales deben ser repartidas de la siguiente manera:
    • Todo el direccionamiento debe ser entregado por la empresa OTEON S.A.
    • La VLAN de usuarios debe tener capacidad para un máximo de 255 hosts.
    • La VLAN de proveedores no puede superar más de 16 hosts.
    • la VLAN de visitantes no puede superar más de 16 hosts.
    • La sede deber tener dos swiches, en el primero deben estar conectados los usuarios, en el segundo los proveedores y visitantes.
  3. La ciudad de Bogotá debe tener dos VLAN creadas para: Usuarios y Servidores, las cuales deben ser repartidas de la siguiente manera:
    • Todo el direccionamiento debe ser entregado por la empresa OTEON S.A.
    • La VLAN de usuarios debe tener capacidad para un máximo de 255 hosts.
    • La VLAN de servidores no puede superar más de 16 hosts.
    • Solo debe existir un swiche.
  4. Todos los PC deben comunicarse con cada una de las áreas creadas.
  5. La empresa OTEON S.A. debe entregar todo el direccionamiento IP.

 

::[SOLUCION]::

Elementos de la topología:

  • Medellín:
    • Un router (ROUTER-MED) conectando con Bogotá.
    • Dos swiches:
      • SW-1: Swiche de usuarios (una VLAN).
      • SW-2: Swiche de proveedores y visitantes (dos VLANs - una para proveedores y otra para visitantes).
  • Bogotá:
    • Un router (ROUTER-BOG) conectando con Medellín.
    • Un swiche:
      • SW-1: Swiche de usuarios y servidores (dos VLANs - una para usuarios y otra para servidores).

 

Direccionamiento de enlace WAN (entre Medellín y Bogotá):

  • El numeral 1 nos dice que el direccionamiento en el enlace WAN no debe pasar de 2 hosts, por lo tanto voy a seleccionar una dirección IP clase C, de la cual me queda el último octeto para direccionar hasta 2 hosts. Veamos:
    • Dirección de red: 192.168.0.0.
    • Máscara de subred: 255.255.255.0.

    Para obtener máximo dos hosts de la dirección de red 192.168.0.0/255.255.255.0 necesito tomar del último octeto, al menos 2 bits de host, ya que 2^2 - 2 = 2 Host. Veamos ese último octeto en binario:

R
R
R
R
R
R
H
H
1
1
1
1
1
1
0
0

Por lo que me quedan 6 bits de subred:

11111100 en decimal equivale a 252. Por lo que la máscara de las subredes será 255.255.255.252. Ahora saquemos las subredes:

256 - 252 = 4 (primera subred y tamaño del bloque).

4 + 4 = 8 (segunda subred).

8 + 4 = 12 (tercera subred).

...

240 + 8 = 248 (subred número 63).

248 + 8 = 252 (subred numero 64, no válida).

Para simplificar voy a tomar la primera subred (192.168.0.4/255.255.255.252) para direccionar el enlace WAN entre las dos ciudades.

Subred Máscara Primer Host Ultimo Host Broadcast
192.168.0.4 255.255.255.252 192.168.0.5 192.168.0.6 192.168.0.7

Bien. Hasta este punto tenemos listo el númeral 1 del problema:

Router Interface Direccion IP
ROUTER-MED WAN 192.168.0.5/255.255.255.252
ROUTER-BOG WAN 192.168.0.6/255.255.255.252

Y solo nos gastamos 2 direcciones de Host de la subred. Tal cual como lo pedía el enunciado.

 

Direccionamiento de Medellín:

  • El númeral 2 nos dice en la primera parte que la VLAN de usuarios debe tener capacidad para 255 hosts, por lo que aquí basta con elegir cualquier dirección de red clase C a excepción de la subred 192.168.0.0/255.255.255.0 que ya fue elegida para direccionar el enlace WAN entre las dos ciudades. Así que para no enredarme la vida voy a elegir la dirección de red 192.168.1.0/255.255.255.0 para direccionar la VLAN de usuarios de la ciudad de Medellín.
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.1.0 255.255.255.0 192.168.1.1 192.168.1.254 192.168.1.255
  • En la segunda parte este mismo numeral nos dice que la VLAN de proveedores no debe superar más de 16 Hosts, por lo que vuelvo a elegir otra dirección de red clase C y tomo 5 bits de hosts ya que 2^5 - 2 = 30. ¿Y porque no tomo 4 bits de hosts ya que 2^4 = 16? Recordemos que la operación 2^y incluye restar al resultado el número 2, por lo que si elijo 2^4 - 2 = 14 host, lo cual no cumple con el requerimiento del enunciado.

Por comodidad voy a elegir el siguiente segmento IP clase C:

  • Dirección de red: 192.168.2.0.
  • Máscara de subred: 255.255.255.0

Voy a tomar del último octeto 5 bits de host para obtener 30 host por subred. Veámos este octeto en binario:

R
R
R
H
H
H
H
H
1
1
1
0
0
0
0
0

Por lo que me quedan 3 bits para subred.

Ahora, 11100000 en decimal equivale a 224. Por lo que la máscara de subred será 255.255.255.224. Saquemos las subredes.

256 - 224 = 32 (primera subred y tamaño del bloque).

32 + 32 = 64 (segunda subred).

64 + 32 = 96 (tercera subred).

...

Para simplificar voy a tomar la primera subred (192.168.2.32/255.255.255.224) para direccionar la VLAN de proveedores:

Subred Máscara Primer Host Ultimo Host Broadcast
192.168.2.32 255.255.255.224 192.168.2.33 192.168.2.62 192.168.2.63
  • La tercera parte de este numeral nos pide que la VLAN de visitantes no puede superar más de 16 Hosts y para no reptir el proceso anterior digamos que se tomó el segmento clase C 192.168.3.0 con máscara 255.255.255.0 y se le hizo el mismo proceso de subnetting. Por lo que la siguiente tabla sumariza el proceso para la VLAN de usuarios.
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.3.32 255.255.255.224 192.168.3.33 192.168.3.62 192.168.3.63

 

Direccionamiento de Bogotá:

  • La primera parte del numeral 3 nos dice que la VLAN de usuarios debe tener capacidad para un máximo de 255 hosts. Aquí vuelve y juega, seleccionamos una dirección de red clase C purita que no entre en conflicto con los segmentos seleccionados para el direccionamiento de Medellín. Propongo entonces: 192.168.100.0/255.255.255.0
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.100.0 255.255.255.0 192.168.100.1 192.168.100.254 192.168.100.255
  • La segunda parte del numeral 3 nos dice que la VLAN de servidores no puede superar más de 16 hosts, por lo que aquí metemos otro gol diciendo que vamos a seleccionar una dirección de red clase C, digamos 192.168.101.0/255.255.255.0 y que pasando este segmento de red por un proceso de subnetting similar al de la VLAN de proveedores para la ciudad de Medellín obtenemos:
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.101.32 255.255.255.224 192.168.101.33 192.168.101.62 192.168.101.63

 

Tenemos hasta este punto todo el direccionamiento IP de las dos ciudades (Medellín y Bogotá) incluyendo el direccionamiento del enlace WAN entre ambas ciudades.

  • Enlace WAN
Router Interface Direccion IP
ROUTER-MED WAN 192.168.0.5/255.255.255.252
ROUTER-BOG WAN 192.168.0.6/255.255.255.252
  • VLAN: 2 usuarios Medellín
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.1.0 255.255.255.0 192.168.1.1 192.168.1.254 192.168.1.255
  • VLAN: 3 proveedores Medellín
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.2.32 255.255.255.224 192.168.2.33 192.168.2.62 192.168.2.63
  • VLAN: 4 visitantes Medellín
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.3.32 255.255.255.224 192.168.3.33 192.168.3.62 192.168.3.63
  • VLAN: 2 usuarios Bogotá
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.100.0 255.255.255.0 192.168.100.1 192.168.100.254 192.168.100.255
  • VLAN: 3 servidores Bogotá
Subred Máscara Primer Host Ultimo Host Broadcast
192.168.101.32 255.255.255.224 192.168.101.33 192.168.101.62 192.168.101.63

Nota: Vamos a seleccionar como puerta de enlace de cada subred (para las VLANs) la última dirección IP de host disponible de cada subred:

  • Subred: 192.168.1.0, puerta de enlace: 192.168.1.254.
  • Subred: 192.168.2.32, puerta de enlace: 192.168.2.62.
  • Subred: 192.168.3.32, puerta de enlace: 192.168.3.62.
  • Subred: 192.168.100.0, puerta de enlace: 192.168.100.254.
  • Subred: 192.168.101.32, puerta de enlace: 192.168.101.62.

 

Topología

 

Lista detallada de configuraciones

Aquí incluyo los comandos más importantes hechos sobre los dispositivos más importantes de la topología. Al final de este artículo se encuentran los archivos de Packet Tracer con la topología totalmente configurada. Usted por analogía debe extrapolar estos resultados hacia los dispositivos que no se detallan en las siguientes tablas.

  • ROUTER-MED (Router Medellín)
Comando Descripción
interface serial 0/0
Entro a la configuración de la interface serial 0/0. Esta interface es la que hace el enlace con el router de la ciudad de Bogotá.
ip address 192.168.0.5 255.255.255.252
Se le asigna la dirección IP y la máscara de subred a la interface serial 0/0.
clock rate 64000
Ya que esta interface es el componente DCE de la comunicación, nos toca establecer el reloj para la sincronización de la interface serial con su extremo.
interface FastEthernet 1/0.1
Creamos la interface virtual 1/0.1 a partir de la interface 1/0. Recordemos que la interface 1/0 es la que está de cara a SW-1.
encapsulation dot1q 2
Definimos la encapsulación que va a manejar la interface. Como estamos hablando de VLANs definimos la encapsulación 802.1Q y a continuación definimos la VLAN a la que está asociada esta sub-interface. En este caso la VLAN 2 (Usuarios). Recordemos que esta interface es una "troncal".
ip address 192.168.1.254 255.255.255.0
Definimos la dirección IP y la máscara de subred de cada subinterface. Esta dirección IP que le asignamos es la que corresponde con la VLAN 2 (Usuarios) en Medellín.
interface FastEthernet 1/0.2
Definimos la sub-interface para manejar la VLAN 3 (Proveedores) en Medellín y repetimos los mismos pasos anteriores de acuerdo al direccionamiento seleccionado para la VLAN 3.
encapsulation dot1q 3  
ip address 192.168.2.62 255.255.255.224  
interface FastEthernet 1/0.3
Definimos la sub-interface para manejar la VLAN 4 (Visitantes) en Medellín y repetimos los mismos pasos que se hicieron para la VLAN 2 de acuerdo con el direccionamiento seleccionado para la VLAN 4.
encapsulation dot1q 4  
ip address 192.168.3.62 255.255.255.224  
ip route 192.168.100.0 255.255.255.0 192.168.0.6

Definimos una ruta estática diciendo como alcanzar la subred 192.168.100.0 (VLAN Usuarios Bogotá) que están en la ciudad de Bogotá. Aquí recordemos la sintaxis:

ip route <red destino> <mascara red destino> <puerta de enlace>

ip route 192.168.101.32 255.255.255.224 192.168.0.6
Definimos otra ruta estática diciendo como alcanzar la subred 192.168.101.32 (VLAN Servidores Bogotá) que está en la ciudad de Bogotá.

  • SW-1 (Swiche - 1, Medellín)
Comando Descripción
SW-USUARIOS(config)# interface fastEthernet 0/1
Ingresamos a la configuración de la interface Fasth Ethernet 0/1. Esta interface es la que está pegada directamente a ROUTER-MED. Como esta interface va a transportar datos de todas las VLANs de la ciudad de Medellín, hay que definirla como una interface de tipo troncal para que agregue la correspondiente encapsulación 802.1Q a las tramas Ethernet.
SW-USUARIOS(config-if)# switchport mode trunk
Le decimos a la interface Fast Ethernet 0/1 que estará definida como una interface de tipo troncal.
SW-USUARIOS(config)# vlan 2
Definimos la VLAN 2.
SW-USUARIOS(config-vlan)# name USUARIOS
Le asignamos un nombre a la VLAN 2. En este caso le asignamos el nombre USUARIOS.
SW-USUARIOS(config)# interface fastEthernet 0/2
Entramos a la configuración del puerto Fast Ethernet 0/2 del swiche. Es en este puerto en donde tenemos conectado el equipo 192.168.1.1.
SW-USUARIOS(config-if)# swicth port mode access
Definimos que el puerto no es un puerto de "troncal" sino un puerto de acceso.
SW-USUARIOS(config-if)# switchport access vlan 2
Le decimos a la interface Fast Ethernet 0/2 que pernece a la VLAN 2 creada previamente.
SW-USUARIOS(config)# interface fastEthernet 0/3
Entramos a la interface Fast Ethernet 0/3 para decirle que pertenece a la VLAN 2 como se hizo previamente con la interface Fast Ethernet 0/2. Esta interface es la que conecta al equipo 192.168.1.2 de la topología.
SW-USUARIOS(config)# vlan 3
Definimos en este Swiche la VLAN 3.
SW-USUARIOS(config-vlan)# name PROVEEDORES
Definimos el nombre de la VLAN 3 pero no le asignamos ninguna interface, solo la definimos.
SW-USUARIOS(config)# vlan 4
Definimos la VLAN 4.
SW-USUARIOS(config-vlan)# name VISITANTES
Definimos el nombre para la VLAN 4.
SW-USUARIOS(config)# interface fastEthernet 0/4
Entramos a la configuración de la interface Fast Ethernet 0/4. Esta interface es la que conecta el equipo 192.168.3.34 que pertenece a la VLAN de visitantes.
SW-USUARIOS(config-if)# swicth port mode access
SW-USUARIOS(config-if)# switchport access vlan 4
Le decimos a la interface que pertenece a la VLAN 4 (la de visitantes).
SW-USUARIOS(config)# interface fastEthernet 0/24
Esta interface también tiene un propósito especial: es la que conecta a SW-1 con SW-2. Como esta interface está interconectando a estos dos swiches, esta interface debe configurarse de modo troncal para que pueda transportar los datos de las VLANs entre ambos swiches.
SW-USUARIOS(config-if)# switchport mode trunk
Definimos la interface de tipo "troncal". El proceso hay que realizarlo exactamente igual en la interface Fast Ethernet 0/24 en SW-2.

 

Hasta aquí considero que es suficiente ilustrar el proceso de configuración de un Swiche y un Router. Con estas explicaciones es suficiente para realizar las configuraciones de los dispositivos que faltan en la topología. Solo ajuste los parámetros de acuerdo a las VLANs y al direccionamiento seleccionado.

 

::[ARCHIVOS]::

  • Archivo de la topología realizado en Packet Tracer 4.1:
    • LAB-VLAN-1.rar (md5sum: eeed953ff8d2c6ce46cc387b3503dc5b *LAB-VLAN-1.rar)